让emlog兼容PHP7的方法

时间:2019-3-5   作者:小白   分类:   热度:83°    
时间:2019-3-5   分类:    热度:83  
在PHP7的环境中直接安装emlog时,会出现各种报错,虽然emlog5.3.1已经使用了mysqli连接类,但是为了兼容默认还是用的mysql,因为PHP7已经不支持mysql扩展了,但是支持mysqli和pdo_mysql。所以这里还是介绍如何使用mysqli来安装emlog。 以下是修改emlog安装程序,无报错安装。如果是实际环境请在本地环境模拟后成功后再变换。 1.修改include\lib\option.php const DEFAULT_MYSQLCONN = 'mysql'; 改为 const DEF...

阅读全文>>

返回顶部    首页    手机版本    后花园   会员注册   
版权所有:小白博客    站长: 小白    主题唯美式模板  程序:emlog     小白网络